[webkit-dev] Web Audio API

Chris Marrin cmarrin at apple.com
Tue Aug 24 16:22:26 PDT 2010

On Aug 24, 2010, at 3:53 PM, Chris Rogers wrote:

> Hi Chris,
> That also sounds like a reasonable naming scheme.  The only counter-argument I would have is that we have several directories in WebCore which don't have the 'web' prefix such as:
> WebCore/notifications
> WebCore/storage
> WebCore/workers
> (and not webnotifications, webstorage, webworkers)
> I guess I'm just trying to keep to a simpler naming convention.  Since WebKit is all about the web, it seems like 'web' is implied.
> Either way is fine with me, but I have a preference for the simpler 'audio'.

Yes, WebKit it not consistent. But websockets does follow this model. And the word 'audio' is so generic, I think making it more specific would help people understand what it is better. Also, the name of the spec is "Web Audio API", so using the "web" prefix seems like the best choice. 

cmarrin at apple.com

More information about the webkit-dev mailing list