[webkit-dev] Web Audio API

Chris Rogers crogers at google.com
Tue Aug 24 15:53:47 PDT 2010

Hi Chris,

That also sounds like a reasonable naming scheme.  The only counter-argument
I would have is that we have several directories in WebCore which don't have
the 'web' prefix such as:


(and not webnotifications, webstorage, webworkers)

I guess I'm just trying to keep to a simpler naming convention.  Since
WebKit is all about the web, it seems like 'web' is implied.

Either way is fine with me, but I have a preference for the simpler 'audio'.


On Tue, Aug 24, 2010 at 3:10 PM, Chris Marrin <cmarrin at apple.com> wrote:

> On Aug 24, 2010, at 12:05 PM, Chris Rogers wrote:
> >
> > After discussing the directory layout in some detail with Eric Carlson,
> Chris Marrin, Simon Fraser, and Jer Noble, we've decided that the files will
> primarily live in two places:
> >
> > WebCore/audio
> > WebCore/platform/audio
> >
> > I know that some had expressed concern that a directory called 'audio' in
> WebCore would be confused with the audio element.  The reason I think
> 'audio' would be a good name is because the API does have a direct
> relationship to the audio element and, over time, when the API becomes more
> broadly used will be associated with the audio capabilities of the web
> platform.  That said, if anybody has grave concerns over this name, then we
> can discuss alternatives.
> I'd rather see the directories named webaudio and the enabled named
> WEBAUDIO. This would match the naming of 'websockets' (although not web
> workers, which is simply named 'workers'. I agree that this is directly
> related to the audio element, but it is an optional piece (hence the enable
> flag) and so I think it should have its own naming.
> -----
> ~Chris
> cmarrin at apple.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20100824/e355518c/attachment.html>

More information about the webkit-dev mailing list