[webkit-dev] Making GRefPtr more general

Eric Seidel eric at webkit.org
Mon Aug 23 10:06:41 PDT 2010

Would this then combine with the Mac/Win port's RetainPtr in some way?

On Mon, Aug 23, 2010 at 9:49 AM, Martin Robinson <mrobinson at webkit.org> wrote:
> Recently there was a need to make the smart pointer wrapping GLib
> reference-counted types more general. In this case it was to extend it to Cairo.
> Here is the bug for that: https://bugs.webkit.org/show_bug.cgi?id=44354
> It struck me that the name GRefPtr wasn't very applicable to this type any
> longer, so I changed it to PlatformRefPtr in my patch. That seemed a bit
> wordy and others have suggested PRefPtr. Since this naming affects more
> than just the GTK+ port, I thought I would get some opinions on a name that
> is easy to type and fitting.
> Martin
> _______________________________________________
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

More information about the webkit-dev mailing list