[webkit-dev] Making GRefPtr more general

Martin Robinson mrobinson at webkit.org
Mon Aug 23 09:49:26 PDT 2010

Recently there was a need to make the smart pointer wrapping GLib
reference-counted types more general. In this case it was to extend it to Cairo.

Here is the bug for that: https://bugs.webkit.org/show_bug.cgi?id=44354

It struck me that the name GRefPtr wasn't very applicable to this type any
longer, so I changed it to PlatformRefPtr in my patch. That seemed a bit
wordy and others have suggested PRefPtr. Since this naming affects more
than just the GTK+ port, I thought I would get some opinions on a name that
is easy to type and fitting.


More information about the webkit-dev mailing list