[webkit-dev] [webkit-changes] [57262] trunk/JavaScriptCore

Osztrogonac Csaba oszi at inf.u-szeged.hu
Fri Apr 9 07:35:46 PDT 2010


Hi,

Alexey Proskuryakov írta:
 > "FIXME! " is different from "FIXME: " in that Xcode doesn't recognize
 > it. I'm surprised that style guide doesn't say anything about FIXME vs.
 > TODO.
I wasn't aware of this, thanks for your
advice, I will use "FIXME:" next time.


 > + // [Qt]r57240 broke Qt build (might be a gcc bug)
 > + // FIXME! See: https://bugs.webkit.org/show_bug.cgi?id=37253
 > But I'm not sure if a comment was even needed here - the ugliness of
 > nested #ifs shouts the same.
This patch is only a workaround for buggy gcc. I added this comments,
because I want to avoid that somebody would like to optimize Qt port
and remove these guards.

Ugliness of nested #ifs is another question, I hate them as you.
It would be great if we can define it in Coding Style Guidelines.
We can found different styles for nested #ifdefs in trunk
(for example in JavaScriptCore/wtf/Platform.h(

style-I.)
#if xxx
#if yyy
     ...
#else
     ...
#endif
#endif

style-II.)
#if xxx
#if yyy
     ...
#else
     ...
#endif // yyy
#endif // xxx

style-III.)
#if xxx
     #if yyy
         ...
     #else
         ...
     #endif // yyy
#endif // xxx

style-IV.)
#if xxx
#  if yyy
      ...
#  else
      ...
#  endif
#endif


As for me, I prefer style-III, but all reviewer ask me to modify
my patches into style-I or style-II. I think we should make
consensus which of them is the preferred coding style.

br,
Ossy


More information about the webkit-dev mailing list