[webkit-dev] [webkit-changes] [57262] trunk/JavaScriptCore

Maciej Stachowiak mjs at apple.com
Thu Apr 8 11:27:10 PDT 2010

On Apr 8, 2010, at 11:18 AM, Alexey Proskuryakov wrote:

> On 08.04.2010, at 10:21, Jeremy Orlow wrote:
>> I wasn't even aware that Xcode did recognize it or that we used  
>> that convention because it does.  We should probably document this  
>> somewhere.
> I don't know if that's the original or only reason. Just something I  
> noticed on my own at some point, and thought it was a sufficiently  
> good explanation.
>> I'm surprised that style guide doesn't say anything about FIXME vs.  
>> TODO.
>> What do you mean?  Are you suggesting that we should be using both  
>> and for different purposes?
> Sorry for being unclear. I meant that coding style guidelines should  
> document always using FIXME.

That seems like a good change to the guidelines. Specifically "FIXME:  
" as a prefix, with discouragement of TODO or XXX or other such formats.

  - Maciej

More information about the webkit-dev mailing list