[webkit-dev] AppCache class naming (WAS Re: SharedWorkers alternate design)

Michael Nordman michaeln at google.com
Fri May 29 13:19:17 PDT 2009

>  one might reasonably assume that in Chrome, the renderer process is the back end

Not really. We do use the terms front and back, but they usually refer
to something a bit orthognal to this child/main process distinction...
closer to network stack vs closer to browserui is generally what these
terms refer to.

Anyway... how these terms are used in chromium shouldn't influence our
use of these terms in webcore much... in webcore-land we (me at least)
were thinking 'front' == closer to script and html content, 'back' ==
farther away from that.

> I can make suggestions in the context of reviewing a patch if you guys don't
> want to discuss it any more. I'm not clear enough on how exactly you split
> the classes to make a good suggestion.

That would be great. Here's a patch...

More information about the webkit-dev mailing list