[webkit-dev] SharedWorkers alternate design

Drew Wilson atwilson at google.com
Fri May 22 13:15:45 PDT 2009

Thanks - I hadn't realized that about WebKit style.

I've updated the interfaces to use different verbs (like
"createWorkerProxy()") or omit the verb entirely where appropriate.


On Fri, May 22, 2009 at 12:30 PM, Darin Adler <darin at apple.com> wrote:

> No substantive comment, but a small style comment.
> On May 21, 2009, at 4:20 PM, Drew Wilson wrote:
>   // Static factory method for getting the correct repository
>> implementation for a given browser
>>  static public SharedWorkerRepository* getRepository();
> Generally WebKit does not use the verb "get" to name functions that simply
> return something. Instead for those we simply use a noun.
> If there is some real action involved, then we would want to use a verb,
> but not "get". For example, if the function always creates something we can
> use the word create.
> Sadly we have not yet found a good verb for the common "get or create"
> idiom.
>    -- Darin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20090522/1e375450/attachment.html>

More information about the webkit-dev mailing list