[webkit-dev] SharedWorkers alternate design

Darin Adler darin at apple.com
Fri May 22 12:30:25 PDT 2009

No substantive comment, but a small style comment.

On May 21, 2009, at 4:20 PM, Drew Wilson wrote:

>   // Static factory method for getting the correct repository  
> implementation for a given browser
>   static public SharedWorkerRepository* getRepository();

Generally WebKit does not use the verb "get" to name functions that  
simply return something. Instead for those we simply use a noun.

If there is some real action involved, then we would want to use a  
verb, but not "get". For example, if the function always creates  
something we can use the word create.

Sadly we have not yet found a good verb for the common "get or create"  

     -- Darin

More information about the webkit-dev mailing list