[webkit-dev] Confusion about Webkit method naming convention
abarth at webkit.org
Wed Jun 10 10:23:26 PDT 2009
Usually didXXXX() is a notification that something already happened,
and you might want to respond to that in some way. For example,
didReceiveRedirect means that we already got a redirect from the
network. The implementor of that method might want to do something
about it, like check the phishing database again, etc.
On Wed, Jun 10, 2009 at 9:16 AM, Meryl
Silverburgh<silverburgh.meryl at gmail.com> wrote:
> In Java naming convention, it names method
> boolean isXXXXX() // return certain condition is true or not
> void doXXXXX() // perform some operation
> but in Webkit, its naming convention is
> void didXXXXX()
> what does that mean? does that method it is already done with doing
> XXXXX and didXXXX() is a post processing of XXXX?
> Thank you.
> webkit-dev mailing list
> webkit-dev at lists.webkit.org
More information about the webkit-dev