[webkit-dev] Confusion about Webkit method naming convention

Meryl Silverburgh silverburgh.meryl at gmail.com
Wed Jun 10 09:16:14 PDT 2009


In Java naming convention, it names method
boolean isXXXXX() // return certain condition is true or not
void doXXXXX() // perform some operation

but in Webkit, its naming convention is
void didXXXXX()

what does that mean? does that method it is already done with doing
XXXXX and didXXXX() is a post processing of XXXX?

Thank you.

More information about the webkit-dev mailing list