[webkit-dev] Webkit Building errors in VC++2005

Frank Thomsen fth at trifork.com
Sun Feb 22 00:18:24 PST 2009

Hi Mital

I read that wiki page, as well as followed the guidelines beginning with http://webkit.org/building/tools.html to the lette. I had two colleagues do the same - same result. It was when I found the link included in the last mail that I finally got a breakthrough. There is just too much information missing in the "official" guidelines, I'm sorry to say. I would advice someone to rewrite it :)


From: Mital Vora [mailto:mital.d.vora at gmail.com]
Sent: 22. februar 2009 04:01
To: Frank Thomsen
Cc: Saumya; webkit-dev at lists.webkit.org
Subject: Re: [webkit-dev] Webkit Building errors in VC++2005

It seems that u have not followed the instructions for building webkit in Windows.
refer http://trac.webkit.org/wiki/BuildingOnWindows

also check weather u have all the required packages for cygwin are installed properly. verify wiht the below list.


Mital Vora.

On Sat, Feb 21, 2009 at 10:26 PM, Frank Thomsen <fth at trifork.com<mailto:fth at trifork.com>> wrote:


I ran into the exact same problem (amongst a lot of others); The guideline on webkit.org<http://webkit.org> it far from helpful. So I dug through the net and found the following two pages. Hopefully they can be of some assistance. Pay close(!) attention to the first - a lot of good hints!



Regards, Frank

From: webkit-dev-bounces at lists.webkit.org<mailto:webkit-dev-bounces at lists.webkit.org> [mailto:webkit-dev-bounces at lists.webkit.org<mailto:webkit-dev-bounces at lists.webkit.org>] On Behalf Of Saumya
Sent: 21. februar 2009 17:49
To: webkit-dev at lists.webkit.org<mailto:webkit-dev at lists.webkit.org>
Subject: [webkit-dev] Webkit Building errors in VC++2005

I tried to build webkit in VC++ 2005.. I was about to solve the earlier problem but now  when i debug an error says that 'Error    1    Error result 1 returned from 'C:\WINDOWS\system32\cmd.exe'. i have also edited the embed manifest in the manifest tool in configuration properties in each project  to No but still the error is there...
build log is listed below...

Creating temporary file "C:\cygwin\home\Saumya\webkit\WebKitBuild\obj\ImageDiff\Release\BAT00007355205172.bat" with contents


@echo off

set PATH=%SystemDrive%\cygwin\bin;%PATH%

if exist "C:\cygwin\home\Saumya\webkit\WebKitBuild\buildfailed" grep XXImageDiffXX "C:\cygwin\home\Saumya\webkit\WebKitBuild\buildfailed"

if errorlevel 1 exit 1

echo XXImageDiffXX > "C:\cygwin\home\Saumya\webkit\WebKitBuild\buildfailed"

if errorlevel 1 goto VCReportError

goto VCEnd


echo Project : error PRJ0019: A tool returned an error code from "Performing Pre-Build Event..."

exit 1



Creating command line "C:\cygwin\home\Saumya\webkit\WebKitBuild\obj\ImageDiff\Release\BAT00007355205172.bat"

And there is another error saying ' C2370: 'CSSValue' : redefinition; different storage class    C:\cygwin\home\Saumya\webkit\WebKitBuild\obj\WebCore\DerivedSources\CSSValueKeywords.h  '

Please Help...

webkit-dev mailing list
webkit-dev at lists.webkit.org<mailto:webkit-dev at lists.webkit.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-dev/attachments/20090222/3c8187e0/attachment.html>

More information about the webkit-dev mailing list