[webkit-dev] Renaming WebCore/dom/ClassNames
japhet at google.com
Mon Dec 7 15:33:25 PST 2009
(https://bugs.webkit.org/show_bug.cgi?id=32250 is the relevant bug)
Summary: ClassNames used to be used only for class names, but its behavior
meets the requirements for HTML5's strings of space separated tokens. If
folks are ok with it, I'd like to rename ClassNames to something more
generic so that it is more appropriate to use it for HTML5 features (the
only current html5-flavored usage I know of is the one I introduced in
I was thinking of renaming it to SpaceSplitString, or AtomicStringList (it's
previous name), but I'm not hung up on any particular name.
Any thoughts or objections?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-dev