[webkit-dev] Fwd: Rename TypeInfo -> JSTypeInfo?

Kevin Ollivier kevino at theolliviers.com
Tue Sep 23 09:11:19 PDT 2008

Hi all,

I sent this message to the mailing list yesterday, but it seems it  
never made it, so I'm resending.


Begin forwarded message:

> From: Kevin Ollivier <kevino at theolliviers.com>
> Date: September 22, 2008 12:13:24 PM PDT
> To: webkit-dev at lists.webkit.org
> Subject: Rename TypeInfo -> JSTypeInfo?
> Hi all,
> We're having a problem on the Windows version of wxWebKit where  
> #include <typeinfo> is actually now including JavaScriptCore/kjs/ 
> TypeInfo.h, which needless to say is not a good thing. ;-) I think  
> this problem stems from the fact that we (the wx port, that is)  
> don't use the 'framework' approach for JSC headers yet (and thus  
> need JavaScriptCore/kjs on our include path), but I think in general  
> it's good practice to avoid using system header names just for  
> readability purposes. Does anyone see a problem with renaming  
> TypeInfo to JS(C)TypeInfo, both header name and class?
> Thanks,
> Kevin

More information about the webkit-dev mailing list