[webkit-dev] renaming some things in JavaScriptCore

Maciej Stachowiak mjs at apple.com
Mon Jun 16 14:56:24 PDT 2008

On Jun 16, 2008, at 12:49 PM, Geoffrey Garen wrote:

>> I like the idea. But I'm not crazy about the three WebKit namespaces
>> being WTF, JSC, and WebCore. One of these things is not like the  
>> others!
> How about "JSCore?" We already use "JS" as an abbreviation for  
> "JavaScript" all over the place, so "JSCore" seems like a natural  
> shortening of "JavaScriptCore."

Right now, KJS:: appears a lot in headers, so it would be a little  
verbose to say JSCore. And I'm not sure it's a whole lot clearer than  
JSC. But I guess it is a matter of taste to some extent.


More information about the webkit-dev mailing list