[webkit-dev] renaming some things in JavaScriptCore

Maciej Stachowiak mjs at apple.com
Sun Jun 15 16:04:18 PDT 2008

On Jun 15, 2008, at 8:51 AM, David Hyatt wrote:

> On Jun 15, 2008, at 12:43 AM, Maciej Stachowiak wrote:
>>>> Another thought that came up is that perhaps we should change our
>>>> namespace from KJS to JSC.
>>> I like the idea. But I'm not crazy about the three WebKit namespaces
>>> being WTF, JSC, and WebCore. One of these things is not like the
>>> others!
>> Should the WebCore namespace be WC? That somehow seems less tasty  
>> than
>> the others.
> No!  Please leave the WebCore namespace alone.
> Use JavaScriptCore instead of JSC if you are worried about  
> consistency.

To be clear, I am not in favor of renaming the WebCore namespace. But  
changing the KJS namespace to JavaScriptCore instead of JSC would be  
awkward, because it is often actually used to qualify symbols (for  
instance in WebCore headers) and making it very long would make the  
code hard to read.


More information about the webkit-dev mailing list