[webkit-dev] renaming some things in JavaScriptCore

David Hyatt hyatt at apple.com
Sun Jun 15 08:51:53 PDT 2008

On Jun 15, 2008, at 12:43 AM, Maciej Stachowiak wrote:

>>> Another thought that came up is that perhaps we should change our
>>> namespace from KJS to JSC.
>> I like the idea. But I'm not crazy about the three WebKit namespaces
>> being WTF, JSC, and WebCore. One of these things is not like the
>> others!
> Should the WebCore namespace be WC? That somehow seems less tasty than
> the others.

No!  Please leave the WebCore namespace alone.

Use JavaScriptCore instead of JSC if you are worried about consistency.

(hyatt at apple.com)

More information about the webkit-dev mailing list