[webkit-dev] renaming some WebCore, too
Darin Adler
darin at apple.com
Fri Jun 13 16:26:24 PDT 2008
As with the JavaScriptCore renames, I have some WebCore renames I'd
like to do.
Take the K out of KURL.
"KURL" => "URL",
"KURLCFNet" => "URLCF",
"KURLMac" => "URLMac",
"KURL_H_" => "URL_h",
Use a less confusing name for the base class for all form controls.
It's hard to understand how HTMLGenericFormElement (a control within a
form) differs from HTMLFormElement (the form itself).
"HTMLGenericFormElement" => "HTMLFormControlElement",
"HTMLGenericFormElement_h" => "HTMLFormControlElement_h",
Some have proposed I should omit the "HTML" prefix from the name since
it's not part of the public HTML DOM.
Change the renderer for the viewport to be named RenderViewport
instead of RenderView.
"RenderView" => "RenderViewport",
Unify the names of ThreadSafeShared and RefCounted.
"ThreadSafeShared" => "ThreadSafeRefCounted",
Retire obsolete "domString" nomenclature.
"domString" => "string",
Streamline the names of functions to get to parts of the Frame object
(as in the tree() function to get to the frame tree):
"animationController" => "animation",
"scriptProxy" => "script",
"selectionController" => "selection",
Stop using "kjs" in the names of files in the WebCore DOM binding code
(which was never really part of kjs in the first place).
"kjs_binding" => "JSDOMBinding",
"kjs_binding_h" => "JSDOMBinding_h",
"kjs_proxy" => "ScriptController",
"kjs_proxy_h" => "ScriptController_h",
Start using the term "bridged object" instead of "runtime object" for
things that we bridge to JavaScript. This is probably the least-
refined category — there are probably a lot more names that should
change here and I'm not sure "bridged" is a good term for these.
"RuntimeObjectImp" => "BridgedObject",
"RootObject" => "BridgedObjectsRoot",
"addRuntimeObject" => "addObject",
"removeRuntimeObject" => "removeObject",
"m_runtimeObjects" => "m_objects",
"runtime_object" => "BridgedObject",
"runtime_root" => "BridgedObjectsRoot",
"RUNTIME_ROOT_H_" => "BridgedObjectsRoot_h",
Please let me know if you have comments about these name changes.
Again, my proposal would be to do these in batches that correspond to
the sections above.
-- Darin
More information about the webkit-dev
mailing list