[webkit-dev] WebKit Fails to build in XCode 3.1

Samuel Davis sjd_net at mac.com
Wed Jul 2 10:54:45 PDT 2008

Hi Mark,

This problem just won't go away :-(


Checking Dependencies...

The following build commands failed:
	CopyStringsFile /Users/samueljd/WebKit/WebKitBuild/Release/ 
InfoPlist.strings English.lproj/InfoPlist.strings
(1 failure)

When I first installed the SVN client and checked out the WebKit trunk  
I was able to build without any problems.  The problems occurred some  
weeks later when my internet connection went down while I was checking  
out an updated WebKit trunk.  I have since deleted the old version of  
WebKit trunk from my machine and checked out a spanking new one but  
I'm still not able to build the target on my machine.  Believe you me  
this is really frustrating mainly because I can't see why I can't  
build targets anymore even with a brand new trunk.  Do I need to  
update my SVN client?

While building WebKit with command-line in the Terminal, the output  
shows lots of compiler commands but there is nothing in it that I can  
identify as a compiler error.  So I tried a creative approach to  
solving the problem by attempting to build JavaScriptCore.xcodeproj in  
XCode.  The JavaScriptCore target built successfully without any  
errors.  However, when I tried to build JavaScriptGlue.xcodeproj  
within XCode I had numerous errors (53) as apposed to a single Error  
when using the command-line.  Perhaps this suggest that there is some  
inter-dependancies between the sub-projects (i.e. JavaScriptCore,  
JavaScriptGlue, WebCore and WebKit) when building WebKit, hence the  
reason for the build pearl script.

Here is where the command that fails is first displayed the Terminal:

CopyStringsFile /Users/samueljd/WebKit/WebKitBuild/Release/ 
InfoPlist.strings English.lproj/InfoPlist.strings
     mkdir /Users/samueljd/WebKit/WebKitBuild/Release/ 
     cd /Users/samueljd/WebKit/JavaScriptGlue
Contents/Resources/copystrings --validate --inputencoding UTF-16 -- 
outputencoding UTF-16 English.lproj/InfoPlist.strings --outdir /Users/ 
Usage: iconv [-c] [-s] [-f fromcode] [-t tocode] [file ...]
or:    iconv -l

After this output, there are a lot of compiler commands starting with  
CompileC but I can't see anything that looks like an error code or  
output.  Strange problem indeed!

Do you know of any creative ways in which I could start building  
WebKit again on my local machine?  Any suggestions would be much  
appreciated :-)

Best regards,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.webkit.org/pipermail/webkit-dev/attachments/20080702/09794d32/attachment.html 

More information about the webkit-dev mailing list