[webkit-dev] build problem on Windows

Joonwon Yi joonwon at veloxsoft.com
Mon Jan 7 18:35:11 PST 2008

Hi, all.

I'm trying to build the webkit on Windows(XP) and I have trouble.

1. First, I tried to follow instructions on the website. 
After installing Visual Studio 2005, (re-installing)Cygwin and QuickTime SDK, I checked out the code. Until now fine. But after that I can't build, because I don't have qmake.
With qmake (which I got after building the whole Qt), it is said that WebKit.pro file cannot be found.
$ WebKit/WebKitTools/Scripts/build-webkit
Subroutine main::tmpfile redefined at /usr/lib/perl5/5.8/Exporter.pm line 65.
 at /usr/lib/perl5/5.8/cygwin/POSIX.pm line 19
Subroutine main::tmpnam redefined at /usr/lib/perl5/5.8/Exporter.pm line 65.
 at /usr/lib/perl5/5.8/cygwin/POSIX.pm line 19
Checking mod-date of WebKitSupportLibrary.zip...
Current WebKitSupportLibrary is up to date
Calling 'qmake CONFIG+=qt-port -r OUTPUT_DIR=/cygdrive/d/WebKit/WebKitBuild/Debu
g /cygdrive/d/WebKit/WebKit.pro CONFIG-=release CONFIG+=debug' in /cygdrive/d/We
bKit/WebKitBuild/Debug ...

Cannot find file: \cygdrive\d\WebKit\WebKit.pro.
Failed to setup build environment using qmake!

2. I also tried to find something useful information on wiki. 
After installing (building)Qt 4.3.3, Bison/Gperf/Flex/LibIconv, ActivePerl, I tried to build QtWebKit.
D:\WebKit>perl WebKitTools\Scripts\build-webkit
..\..\..\JavaScriptCore\pcre\pcre_internal.h(119) : error C2065: '__FUNCTION__'
: undeclared identifier
..\..\..\JavaScriptCore\pcre\pcre_internal.h(119) : error C2065: 'uintptr_t' : u
ndeclared identifier
..\..\..\JavaScriptCore\pcre\pcre_internal.h(119) : error C2143: syntax error :
missing ';' before 'constant'
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio\VC98\bin\c
l.exe"' : return code '0x2'

3. This page doesn't seem to help me.

What should I do to build the webkit on Windows?

Thanks in advance.

- joonwon -

More information about the webkit-dev mailing list