[webkit-dev] Problem building/running Webkit with QT4 on Ubuntu

Julien Chaffraix julien.chaffraix at gmail.com
Sat Oct 13 06:47:41 PDT 2007


1. i fetched webkit from here
> 2. i installed libqt4-dev-kdecopy with: apt-get install
> libqt4-dev-kdecopy, as qt4.3 was needed (libqt4-dev is qt4.2.3)
> 3. then i build with: QTDIR=/usr/share/qt4/
> WebKit/WebKitTools/Scripts/build-webkit
> the build failed 2 or 3 times, like some class api were missing or class
> reference missing. Anyway it was easy to fix, so i restart the build and it
> complete successfully.

Did the changes you made were in your environment (installed libraries ...)
or Webkit source ?

The trunk should compile on your platform without modification if you have
all the necessary tools and libraries.

I am using Ubuntu too so I just tried that package you mentioned and I could
compile and run webkit without problem.

Could you try to remove all Webkit files (source and builds) and follow the
explanation on the webkit page again and report if something went wrong ?

4. then i run the browser with: QTDIR=/usr/share/qt4/
> WebKit/WebKitTools/Scripts/run-launcher
> the browser starts, but display the blank window, then whatever address i
> try to browse the window remain blank, while the console display such
> message:
> FIXME: UNIMPLEMENTED: ../../../WebCore/platform/qt/WidgetQt.cpp:120 (virtual void WebCore::Widget::show())
> FIXME: UNIMPLEMENTED: ../../../WebKit/qt/WebCoreSupport/FrameLoaderClientQt.cpp:195 (virtual void WebCore::FrameLoaderClientQt::forceLayoutForNonHTML())
> i had a look at WebCore/platform/qt/WidgetQt.cpp, and it seems the data
> member m_widget is not initialized and so it display the UNIMPLEMENTED error
> message.
> I have to say that i'm a newbie at Linux and Webkit, so my questions below
> might be silly [image: smile]
> 1. i find it strange that i had to fix some compile problem as it seem to
> me that WebKit was already ported to QT4. Am i using the right svn trunk ?

There is only one trunk in svn and the url you gave is the right one.

2. am i missing some library ? i've installed libqt4-dev-kdecopy only, do i
> need libqt4-core-kdecopy ? is there any other dependency ?

According to http://packages.ubuntu.com/feisty/libdevel/libqt4-dev-kdecopy ,
liqt4-dev-kdecopy depends on liqt4-core-kdecopy so it is already installed.
Normally if you have managed to compile and run the application, that means
that you have the required libraries.

3. i also find strange that the folder WebKit\WebKitQt\QtLauncher is always
> empty, shouldn't it have some QtLauncher.pro and other files ?
> 4. can somebody also recommend me a good development tools/ide on Linux
> for C++ development.

You have a wide range of development tools under linux. It will widely
depend on what you want as a development environment.
You could use an editor like vim, emacs, gedit or Kate and do the
compilation in a terminal or an IDE like Anjuta (designed for C/C++),
Eclipse (mainly for Java but has a C/C++ extension) or KDevelop. That list
is far from exhaustive.
You should just try some and take the one that suits you most.

Hope it helps,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.macosforge.org/pipermail/webkit-dev/attachments/20071013/95b79cd8/attachment.html

More information about the webkit-dev mailing list