[webkit-dev] upcoming renaming, your chance for feedback

Darin Adler darin at apple.com
Sun Jun 19 21:55:39 PDT 2005

I am planning on renaming the following classes, source files, and  
methods in WebKit:

     WebBaseResourceHandleDelegate -> WebLoader
     WebMainResourceClient -> WebMainResourceLoader
     WebSubresourceClient -> WebSubresourceLoader
     WebNetscapePluginConnectionDelegate ->  
     subresourceClients -> subresourceLoaders
     mainClient -> mainResourceLoader
     plugInStreamClients -> plugInStreamLoaders
     _addSubresourceClient -> _addSubresourceLoader
     _removeSubresourceClient -> _removeSubresourceLoader
     _addPlugInStreamClient -> _addPlugInStreamLoader
     _removePlugInStreamClient -> _removePlugInStreamLoader

Let me know if you have any thoughts on the new names before I do  
this. I'll wait at least a couple of days before I do it (and maybe  
even a few weeks).

     -- Darin

More information about the webkit-dev mailing list