[webkit-changes] [WebKit/WebKit] ac1770: [WPE] Rename WPEMonitor to WPEScreen

Jani Hautakangas noreply at github.com
Tue Oct 22 21:41:04 PDT 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: ac17704df9a56006feef4ceb27d10ab6d7d8414e
      https://github.com/WebKit/WebKit/commit/ac17704df9a56006feef4ceb27d10ab6d7d8414e
  Author: Jani Hautakangas <jani at igalia.com>
  Date:   2024-10-22 (Tue, 22 Oct 2024)

  Changed paths:
    M Source/WebKit/UIProcess/API/wpe/WPEWebViewPlatform.cpp
    M Source/WebKit/UIProcess/glib/DisplayVBlankMonitorDRM.cpp
    M Source/WebKit/UIProcess/glib/ScreenManager.cpp
    M Source/WebKit/UIProcess/glib/ScreenManager.h
    M Source/WebKit/UIProcess/gtk/ScreenManagerGtk.cpp
    M Source/WebKit/UIProcess/wpe/ScreenManagerWPE.cpp
    M Source/WebKit/WPEPlatform/CMakeLists.txt
    M Source/WebKit/WPEPlatform/wpe/WPEDisplay.cpp
    M Source/WebKit/WPEPlatform/wpe/WPEDisplay.h
    R Source/WebKit/WPEPlatform/wpe/WPEMonitor.cpp
    R Source/WebKit/WPEPlatform/wpe/WPEMonitor.h
    A Source/WebKit/WPEPlatform/wpe/WPEScreen.cpp
    A Source/WebKit/WPEPlatform/wpe/WPEScreen.h
    M Source/WebKit/WPEPlatform/wpe/WPEToplevel.cpp
    M Source/WebKit/WPEPlatform/wpe/WPEToplevel.h
    M Source/WebKit/WPEPlatform/wpe/WPEView.cpp
    M Source/WebKit/WPEPlatform/wpe/WPEView.h
    M Source/WebKit/WPEPlatform/wpe/WPEViewPrivate.h
    M Source/WebKit/WPEPlatform/wpe/drm/CMakeLists.txt
    M Source/WebKit/WPEPlatform/wpe/drm/WPEDisplayDRM.cpp
    M Source/WebKit/WPEPlatform/wpe/drm/WPEDisplayDRMPrivate.h
    R Source/WebKit/WPEPlatform/wpe/drm/WPEMonitorDRM.cpp
    R Source/WebKit/WPEPlatform/wpe/drm/WPEMonitorDRM.h
    R Source/WebKit/WPEPlatform/wpe/drm/WPEMonitorDRMPrivate.h
    A Source/WebKit/WPEPlatform/wpe/drm/WPEScreenDRM.cpp
    A Source/WebKit/WPEPlatform/wpe/drm/WPEScreenDRM.h
    A Source/WebKit/WPEPlatform/wpe/drm/WPEScreenDRMPrivate.h
    M Source/WebKit/WPEPlatform/wpe/drm/WPEToplevelDRM.cpp
    M Source/WebKit/WPEPlatform/wpe/drm/WPEViewDRM.cpp
    M Source/WebKit/WPEPlatform/wpe/drm/wpe-drm.h
    M Source/WebKit/WPEPlatform/wpe/wayland/CMakeLists.txt
    M Source/WebKit/WPEPlatform/wpe/wayland/WPEDisplayWayland.cpp
    M Source/WebKit/WPEPlatform/wpe/wayland/WPEDisplayWaylandPrivate.h
    R Source/WebKit/WPEPlatform/wpe/wayland/WPEMonitorWayland.cpp
    R Source/WebKit/WPEPlatform/wpe/wayland/WPEMonitorWayland.h
    R Source/WebKit/WPEPlatform/wpe/wayland/WPEMonitorWaylandPrivate.h
    A Source/WebKit/WPEPlatform/wpe/wayland/WPEScreenWayland.cpp
    A Source/WebKit/WPEPlatform/wpe/wayland/WPEScreenWayland.h
    A Source/WebKit/WPEPlatform/wpe/wayland/WPEScreenWaylandPrivate.h
    M Source/WebKit/WPEPlatform/wpe/wayland/WPEToplevelWayland.cpp
    M Source/WebKit/WPEPlatform/wpe/wayland/WPEViewWayland.cpp
    M Source/WebKit/WPEPlatform/wpe/wayland/wpe-wayland.h
    M Source/WebKit/WPEPlatform/wpe/wpe-platform.h

  Log Message:
  -----------
  [WPE] Rename WPEMonitor to WPEScreen
https://bugs.webkit.org/show_bug.cgi?id=281751

Reviewed by Carlos Garcia Campos.

The current naming of "WPEMonitor" in the WPE Platform doesn’t fit well across
all device form factors. "WPEMonitor" suggests an individual display screen,
but this naming feels out of place for devices with embedded screen such as
mobile phones.

Additionally, in WebKit, there are many "*Monitor" classes used to monitor
events, progress, and other functionalities. "WPEMonitor" could easily be
confused with these, leading to potential misunderstandings about its purpose.
Therefore, renaming WPEMonitor to WPEScreen would provide a clearer and more
appropriate representation of its function.

* Source/WebKit/UIProcess/API/wpe/WPEWebViewPlatform.cpp:
(WKWPE::ViewPlatform::ViewPlatform):
(WKWPE::ViewPlatform::updateDisplayID):
* Source/WebKit/UIProcess/glib/DisplayVBlankMonitorDRM.cpp:
(WebKit::findCrtc):
(WebKit::findDrmNodeWithCrtc):
(WebKit::DisplayVBlankMonitorDRM::create):
(WebKit::DisplayVBlankMonitorDRM::waitForVBlank const):
* Source/WebKit/UIProcess/glib/ScreenManager.cpp:
(WebKit::ScreenManager::displayID const):
(WebKit::ScreenManager::screen const):
(WebKit::ScreenManager::addScreen):
(WebKit::ScreenManager::removeScreen):
(WebKit::ScreenManager::monitor const): Deleted.
(WebKit::ScreenManager::addMonitor): Deleted.
(WebKit::ScreenManager::removeMonitor): Deleted.
* Source/WebKit/UIProcess/glib/ScreenManager.h:
* Source/WebKit/UIProcess/gtk/ScreenManagerGtk.cpp:
(WebKit::ScreenManager::ScreenManager):
* Source/WebKit/UIProcess/wpe/ScreenManagerWPE.cpp:
(WebKit::ScreenManager::generatePlatformDisplayID):
(WebKit::ScreenManager::ScreenManager):
(WebKit::ScreenManager::updatePrimaryDisplayID):
(WebKit::ScreenManager::collectScreenProperties const):
* Source/WebKit/WPEPlatform/CMakeLists.txt:
* Source/WebKit/WPEPlatform/wpe/WPEDisplay.cpp:
(wpe_display_class_init):
(wpe_display_get_n_screens):
(wpe_display_get_screen):
(wpe_display_screen_added):
(wpe_display_screen_removed):
(wpe_display_get_n_monitors): Deleted.
(wpe_display_get_monitor): Deleted.
(wpe_display_monitor_added): Deleted.
(wpe_display_monitor_removed): Deleted.
* Source/WebKit/WPEPlatform/wpe/WPEDisplay.h:
* Source/WebKit/WPEPlatform/wpe/WPEMonitor.cpp: Removed.
* Source/WebKit/WPEPlatform/wpe/WPEScreen.cpp: Added.
(wpeScreenGetProperty):
(wpe_screen_class_init):
(wpe_screen_get_id):
(wpe_screen_invalidate):
(wpe_screen_get_x):
(wpe_screen_get_y):
(wpe_screen_set_position):
(wpe_screen_get_width):
(wpe_screen_get_height):
(wpe_screen_set_size):
(wpe_screen_get_physical_width):
(wpe_screen_get_physical_height):
(wpe_screen_set_physical_size):
(wpe_screen_get_scale):
(wpe_screen_set_scale):
(wpe_screen_get_refresh_rate):
(wpe_screen_set_refresh_rate):
* Source/WebKit/WPEPlatform/wpe/WPEScreen.h: Renamed from Source/WebKit/WPEPlatform/wpe/WPEMonitor.h.
* Source/WebKit/WPEPlatform/wpe/WPEToplevel.cpp:
(wpe_toplevel_get_screen):
(wpe_toplevel_screen_changed):
(wpe_toplevel_get_monitor): Deleted.
(wpe_toplevel_monitor_changed): Deleted.
* Source/WebKit/WPEPlatform/wpe/WPEToplevel.h:
* Source/WebKit/WPEPlatform/wpe/WPEView.cpp:
(wpeViewGetProperty):
(wpe_view_class_init):
(wpeViewScreenChanged):
(wpe_view_set_toplevel):
(wpe_view_get_screen):
(wpeViewMonitorChanged): Deleted.
(wpe_view_get_monitor): Deleted.
* Source/WebKit/WPEPlatform/wpe/WPEView.h:
* Source/WebKit/WPEPlatform/wpe/WPEViewPrivate.h:
* Source/WebKit/WPEPlatform/wpe/drm/CMakeLists.txt:
* Source/WebKit/WPEPlatform/wpe/drm/WPEDisplayDRM.cpp:
(wpeDisplayDRMConnect):
(wpeDisplayDRMGetNScreens):
(wpeDisplayDRMGetScreen):
(wpe_display_drm_class_init):
(wpeDisplayDRMGetNMonitors): Deleted.
(wpeDisplayDRMGetMonitor): Deleted.
* Source/WebKit/WPEPlatform/wpe/drm/WPEDisplayDRMPrivate.h:
* Source/WebKit/WPEPlatform/wpe/drm/WPEScreenDRM.cpp: Renamed from Source/WebKit/WPEPlatform/wpe/drm/WPEMonitorDRM.cpp.
(wpeScreenDRMInvalidate):
(wpeScreenDRMDispose):
(wpe_screen_drm_class_init):
(wpeScreenDRMCreate):
(wpeScreenDRMGetMode):
(wpeScreenDRMGetCrtc):
(wpe_screen_drm_get_crtc_index):
* Source/WebKit/WPEPlatform/wpe/drm/WPEScreenDRM.h: Renamed from Source/WebKit/WPEPlatform/wpe/drm/WPEMonitorDRM.h.
* Source/WebKit/WPEPlatform/wpe/drm/WPEScreenDRMPrivate.h: Renamed from Source/WebKit/WPEPlatform/wpe/drm/WPEMonitorDRMPrivate.h.
* Source/WebKit/WPEPlatform/wpe/drm/WPEToplevelDRM.cpp:
(wpeToplevelDRMConstructed):
(wpeToplevelDRMGetScreen):
(wpe_toplevel_drm_class_init):
(wpeToplevelDRMGetMonitor): Deleted.
* Source/WebKit/WPEPlatform/wpe/drm/WPEViewDRM.cpp:
(wpeViewDRMConstructed):
(wpeViewDRMCommitAtomic):
(wpeViewDRMCommitLegacy):
(wpeViewDRMScheduleCursorUpdate):
* Source/WebKit/WPEPlatform/wpe/drm/wpe-drm.h:
* Source/WebKit/WPEPlatform/wpe/wayland/CMakeLists.txt:
* Source/WebKit/WPEPlatform/wpe/wayland/WPEDisplayWayland.cpp:
(wpeDisplayWaylandDispose):
(wpeDisplayWaylandGetNScreens):
(wpeDisplayWaylandGetScreen):
(wpeDisplayWaylandFindScreen):
(wpe_display_wayland_class_init):
(wpeDisplayWaylandGetNMonitors): Deleted.
(wpeDisplayWaylandGetMonitor): Deleted.
(wpeDisplayWaylandFindMonitor): Deleted.
* Source/WebKit/WPEPlatform/wpe/wayland/WPEDisplayWaylandPrivate.h:
* Source/WebKit/WPEPlatform/wpe/wayland/WPEScreenWayland.cpp: Renamed from Source/WebKit/WPEPlatform/wpe/wayland/WPEMonitorWayland.cpp.
(wpeScreenWaylandInvalidate):
(wpeScreenWaylandDispose):
(wpe_screen_wayland_class_init):
(wpe_screen_wayland_get_wl_output):
* Source/WebKit/WPEPlatform/wpe/wayland/WPEScreenWayland.h: Renamed from Source/WebKit/WPEPlatform/wpe/wayland/WPEMonitorWayland.h.
* Source/WebKit/WPEPlatform/wpe/wayland/WPEScreenWaylandPrivate.h: Renamed from Source/WebKit/WPEPlatform/wpe/wayland/WPEMonitorWaylandPrivate.h.
* Source/WebKit/WPEPlatform/wpe/wayland/WPEToplevelWayland.cpp:
(wpeToplevelWaylandConstructed):
(wpeToplevelWaylandDispose):
(wpeToplevelWaylandGetScreen):
(wpe_toplevel_wayland_class_init):
(wpeToplevelWaylandGetMonitor): Deleted.
* Source/WebKit/WPEPlatform/wpe/wayland/WPEViewWayland.cpp:
(wpeViewWaylandConstructed):
(wpeViewWaylandCanBeMapped):
* Source/WebKit/WPEPlatform/wpe/wayland/wpe-wayland.h:
* Source/WebKit/WPEPlatform/wpe/wpe-platform.h:

Canonical link: https://commits.webkit.org/285586@main



To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications


More information about the webkit-changes mailing list