[webkit-changes] [WebKit/WebKit] 55c8a5: Rename `Cloneable` to `Clonable` to align with Web...

Ahmad Saleem noreply at github.com
Sat Feb 3 23:16:14 PST 2024


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 55c8a567ee56cf6f488c2a1d6a7675088204bea7
      https://github.com/WebKit/WebKit/commit/55c8a567ee56cf6f488c2a1d6a7675088204bea7
  Author: Ahmad Saleem <ahmad.saleem792+github at gmail.com>
  Date:   2024-02-03 (Sat, 03 Feb 2024)

  Changed paths:
    A LayoutTests/fast/shadow-dom/clonable-shadow-root-expected.txt
    A LayoutTests/fast/shadow-dom/clonable-shadow-root.html
    R LayoutTests/fast/shadow-dom/cloneable-shadow-root-expected.txt
    R LayoutTests/fast/shadow-dom/cloneable-shadow-root.html
    M Source/WebCore/dom/Element.cpp
    M Source/WebCore/dom/Range.cpp
    M Source/WebCore/dom/ShadowRoot.cpp
    M Source/WebCore/dom/ShadowRoot.h
    M Source/WebCore/dom/ShadowRoot.idl
    M Source/WebCore/dom/ShadowRootInit.h
    M Source/WebCore/dom/ShadowRootInit.idl

  Log Message:
  -----------
  Rename `Cloneable` to `Clonable` to align with Web Specification wording

https://bugs.webkit.org/show_bug.cgi?id=267634
rdar://problem/121516711

Reviewed by Ryosuke Niwa.

This patch is just rename of `cloneable` to `clonable` as per web-specification [1]:

[1] https://dom.spec.whatwg.org/#shadowroot-clonable

* Source/WebCore/dom/ShadowRoot.cpp:
(ShadowRoot::ShadowRoot):
(ShadowRoot::cloneNodeInternal):
* Source/WebCore/dom/ShadowRoot.h:
* Source/WebCore/dom/ShadowRoot.idl:
* Source/WebCore/dom/ShadowRootInit.h:
* LayoutTests/fast/shadow-dom/clonable-shadow-root.html: Renamed from
LayoutTests/fast/shadow-dom/cloneable-shadow-root.html and rebaselined
* LayoutTests/fast/shadow-dom/clonable-shadow-root-expected.txt: Renamed from
LayoutTests/fast/shadow-dom/cloneable-shadow-root-expected.txt and rebaselined

Canonical link: https://commits.webkit.org/274063@main




More information about the webkit-changes mailing list