[webkit-changes] [WebKit/WebKit] a47510: [Grid] Refactor gridAreaPosition methods to return...
Sammy Gill
noreply at github.com
Mon Aug 12 22:15:57 PDT 2024
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: a4751065b40e61ea644faf6d2e6e231319c6c630
https://github.com/WebKit/WebKit/commit/a4751065b40e61ea644faf6d2e6e231319c6c630
Author: Sammy Gill <sammy.gill at apple.com>
Date: 2024-08-12 (Mon, 12 Aug 2024)
Changed paths:
M Source/WebCore/rendering/RenderGrid.cpp
M Source/WebCore/rendering/RenderGrid.h
Log Message:
-----------
[Grid] Refactor gridAreaPosition methods to return std::pair of LayoutUnits.
https://bugs.webkit.org/show_bug.cgi?id=277984
rdar://problem/133720242
Reviewed by Matthieu Dubet.
These sets of functions take two LayoutUnits by reference and write
to them as out arguments. Instead, we can just return a
std::pair<LayoutUnit, LayoutUnit> to slightly improve the readability of the code in my
opinion.
* Source/WebCore/rendering/RenderGrid.cpp:
(WebCore::RenderGrid::columnAxisOffsetForGridItem const):
(WebCore::RenderGrid::rowAxisOffsetForGridItem const):
(WebCore::RenderGrid::gridAreaPositionForOutOfFlowGridItem const):
(WebCore::RenderGrid::gridAreaPositionForInFlowGridItem const):
(WebCore::RenderGrid::gridAreaPositionForGridItem const):
* Source/WebCore/rendering/RenderGrid.h:
Canonical link: https://commits.webkit.org/282157@main
To unsubscribe from these emails, change your notification settings at https://github.com/WebKit/WebKit/settings/notifications
More information about the webkit-changes
mailing list