[webkit-changes] [WebKit/WebKit] f4648e: Remove unused members of ProvisionalFrameProxy and...

Alex Christensen noreply at github.com
Thu May 18 15:57:13 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: f4648ebc89fd1597a5b798f7ab8a7feb646c581d
      https://github.com/WebKit/WebKit/commit/f4648ebc89fd1597a5b798f7ab8a7feb646c581d
  Author: Alex Christensen <achristensen at apple.com>
  Date:   2023-05-18 (Thu, 18 May 2023)

  Changed paths:
    M Source/WebKit/UIProcess/ProvisionalFrameProxy.cpp
    M Source/WebKit/UIProcess/ProvisionalFrameProxy.h
    M Source/WebKit/UIProcess/SubframePageProxy.cpp
    M Source/WebKit/UIProcess/SubframePageProxy.h
    M Source/WebKit/UIProcess/WebPageProxy.cpp
    M Source/WebKit/UIProcess/WebProcessPool.cpp

  Log Message:
  -----------
  Remove unused members of ProvisionalFrameProxy and SubframePageProxy
https://bugs.webkit.org/show_bug.cgi?id=256984
rdar://109532645

Reviewed by J Pascoe.

ProvisionalFrameProxy is no longer a message sender or receiver.  Its messages go through WebPageProxy.
SubframePageProxy is no longer ever created to own the same domain as the WebPageProxy.  We should
rename it to something like RemotePageProxy for its use in window.open.
Also move the MESSAGE_CHECK in WebPageProxy::didCommitLoadForFrame to before we dereference null.

* Source/WebKit/UIProcess/ProvisionalFrameProxy.cpp:
(WebKit::ProvisionalFrameProxy::didReceiveMessage): Deleted.
(WebKit::ProvisionalFrameProxy::messageSenderConnection const): Deleted.
(WebKit::ProvisionalFrameProxy::messageSenderDestinationID const): Deleted.
* Source/WebKit/UIProcess/ProvisionalFrameProxy.h:
* Source/WebKit/UIProcess/SubframePageProxy.cpp:
(WebKit::SubframePageProxy::SubframePageProxy):
(WebKit::SubframePageProxy::~SubframePageProxy):
* Source/WebKit/UIProcess/SubframePageProxy.h:
(): Deleted.
* Source/WebKit/UIProcess/WebProcessPool.cpp:
(WebKit::WebProcessPool::processForNavigation):

Canonical link: https://commits.webkit.org/264217@main




More information about the webkit-changes mailing list