[webkit-changes] [WebKit/WebKit] 8f5c35: [JSC] rename Array#group/Array#groupByToMap to Obj...

Devin Rousso noreply at github.com
Thu Jun 29 15:21:06 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 8f5c359bbaeb0eb87946cea9ccdb8c52a2c1f143
      https://github.com/WebKit/WebKit/commit/8f5c359bbaeb0eb87946cea9ccdb8c52a2c1f143
  Author: Devin Rousso <hi at devinrousso.com>
  Date:   2023-06-29 (Thu, 29 Jun 2023)

  Changed paths:
    R JSTests/stress/array-group-by-null-or-undefined.js
    R JSTests/stress/array-groupBy.js
    R JSTests/stress/array-groupByToMap.js
    A JSTests/stress/map-groupBy.js
    A JSTests/stress/object-groupBy.js
    M Source/JavaScriptCore/CMakeLists.txt
    M Source/JavaScriptCore/DerivedSources-input.xcfilelist
    M Source/JavaScriptCore/DerivedSources-output.xcfilelist
    M Source/JavaScriptCore/DerivedSources.make
    M Source/JavaScriptCore/JavaScriptCore.xcodeproj/project.pbxproj
    M Source/JavaScriptCore/builtins/ArrayPrototype.js
    A Source/JavaScriptCore/builtins/MapConstructor.js
    M Source/JavaScriptCore/builtins/ObjectConstructor.js
    M Source/JavaScriptCore/runtime/ArrayPrototype.cpp
    M Source/JavaScriptCore/runtime/MapConstructor.cpp
    M Source/JavaScriptCore/runtime/ObjectConstructor.cpp
    M Source/JavaScriptCore/runtime/OptionsList.h

  Log Message:
  -----------
  [JSC] rename Array#group/Array#groupByToMap to Object.groupBy/Map.groupBy
https://bugs.webkit.org/show_bug.cgi?id=258680

Reviewed by Yusuke Suzuki.

Match the latest changes to the "array grouping" spec[1] (proposal[2]).

1. https://tc39.es/proposal-array-grouping/
2. https://github.com/tc39/proposal-array-grouping/

* Source/JavaScriptCore/builtins/ArrayPrototype.js:
(group): Deleted.
(groupToMap): Deleted.
* Source/JavaScriptCore/builtins/MapConstructor.js: Added.
(groupBy):
* Source/JavaScriptCore/builtins/ObjectConstructor.js:
(groupBy): Added.
* Source/JavaScriptCore/runtime/ArrayPrototype.cpp:
(JSC::ArrayPrototype::finishCreation):
* Source/JavaScriptCore/runtime/MapConstructor.cpp:
(JSC::MapConstructor::finishCreation):
* Source/JavaScriptCore/runtime/ObjectConstructor.cpp:
(JSC::ObjectConstructor::finishCreation):
* Source/JavaScriptCore/runtime/OptionsList.h:

* JSTests/stress/array-group-by-null-or-undefined.js: Removed.
* JSTests/stress/map-groupBy.js: Renamed from array-groupBy.js.
* JSTests/stress/object-groupBy.js: Renamed from array-groupByToMap.js.

* Source/JavaScriptCore/CMakeLists.txt:
* Source/JavaScriptCore/DerivedSources.make:
* Source/JavaScriptCore/DerivedSources-input.xcfilelist:
* Source/JavaScriptCore/DerivedSources-output.xcfilelist:
* Source/JavaScriptCore/JavaScriptCore.xcodeproj/project.pbxproj:

Canonical link: https://commits.webkit.org/265632@main




More information about the webkit-changes mailing list