[webkit-changes] [WebKit/WebKit] 8868d3: Web Inspector: give `WI.StepsFunction` a better na...
Devin Rousso
noreply at github.com
Wed Jul 26 18:04:14 PDT 2023
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 8868d37a317d8eda31bc253ded348505281cb4cc
https://github.com/WebKit/WebKit/commit/8868d37a317d8eda31bc253ded348505281cb4cc
Author: Devin Rousso <hi at devinrousso.com>
Date: 2023-07-26 (Wed, 26 Jul 2023)
Changed paths:
M LayoutTests/inspector/animation/resources/lifecycle-utilities.js
R LayoutTests/inspector/unit-tests/geometry-expected.txt
R LayoutTests/inspector/unit-tests/geometry.html
A LayoutTests/inspector/unit-tests/steps-timing-function-expected.txt
A LayoutTests/inspector/unit-tests/steps-timing-function.html
M Source/WebInspectorUI/UserInterface/Main.html
M Source/WebInspectorUI/UserInterface/Models/Animation.js
M Source/WebInspectorUI/UserInterface/Models/Geometry.js
A Source/WebInspectorUI/UserInterface/Models/StepsTimingFunction.js
M Source/WebInspectorUI/UserInterface/Test.html
M Source/WebInspectorUI/UserInterface/Views/AnimationContentView.js
Log Message:
-----------
Web Inspector: give `WI.StepsFunction` a better name and move it to its own file
https://bugs.webkit.org/show_bug.cgi?id=259503
Reviewed by Timothy Hatcher and Tim Nguyen.
`WI.StepsFunction` should really be named `WI.StepsTimingFunction` to convey it's true purpose.
It also shouldn't really be in `Source/WebInspectorUI/UserInterface/Models/Geometry.js` since it has nothing to do with geometry.
* Source/WebInspectorUI/UserInterface/Models/StepsTimingFunction.js: Added.
(WI.StepsTimingFunction):
(WI.StepsTimingFunction.fromString):
(WI.StepsTimingFunction.prototype.get type):
(WI.StepsTimingFunction.prototype.get count):
(WI.StepsTimingFunction.prototype.copy):
(WI.StepsTimingFunction.prototype.toString):
* Source/WebInspectorUI/UserInterface/Models/Geometry.js:
(WI.Spring):
(WI.StepsFunction): Deleted.
(WI.StepsFunction.fromString): Deleted.
(WI.StepsFunction.prototype.get type): Deleted.
(WI.StepsFunction.prototype.get count): Deleted.
(WI.StepsFunction.prototype.copy): Deleted.
(WI.StepsFunction.prototype.toString): Deleted.
* Source/WebInspectorUI/UserInterface/Models/Animation.js:
(WI.Animation.prototype._updateEffect):
* Source/WebInspectorUI/UserInterface/Views/AnimationContentView.js:
(WI.AnimationContentView.prototype._refreshPreview):
* Source/WebInspectorUI/UserInterface/Main.html:
* Source/WebInspectorUI/UserInterface/Test.html:
* LayoutTests/inspector/animation/resources/lifecycle-utilities.js:
* LayoutTests/inspector/unit-tests/geometry.html:
* LayoutTests/inspector/unit-tests/geometry-expected.txt:
* LayoutTests/inspector/unit-tests/steps-timing-function.html: Added.
* LayoutTests/inspector/unit-tests/steps-timing-function-expected.txt: Added.
Canonical link: https://commits.webkit.org/266345@main
More information about the webkit-changes
mailing list