[webkit-changes] [WebKit/WebKit] 638ac8: Align some internal URL concepts with the URL Stan...

Anne van Kesteren noreply at github.com
Sun Jul 16 03:11:02 PDT 2023


  Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 638ac8184b3860aafc3d68fec13300730af06a6d
      https://github.com/WebKit/WebKit/commit/638ac8184b3860aafc3d68fec13300730af06a6d
  Author: Anne van Kesteren <annevk at annevk.nl>
  Date:   2023-07-16 (Sun, 16 Jul 2023)

  Changed paths:
    M Source/WTF/wtf/URL.cpp
    M Source/WTF/wtf/URL.h
    M Source/WTF/wtf/URLParser.cpp
    M Source/WebCore/html/URLDecomposition.cpp
    M Source/WebCore/page/csp/ContentSecurityPolicy.cpp

  Log Message:
  -----------
  Align some internal URL concepts with the URL Standard
https://bugs.webkit.org/show_bug.cgi?id=259245
rdar://112326744

Reviewed by Alex Christensen.

This is a minor refactoring to align with URL Standard changes:

* Rename cannotBeABaseURL to hasOpaquePath.
* Remove isHierarchical and friends as they are the same as
  hasOpaquePath.
* As an opaque path implies a null host, a null host check suffices.

Also add a FIXME to CSP as it does not appear to follow the
specification for reporting URLs.

* Source/WTF/wtf/URL.cpp:
(WTF::URL::invalidate):
(WTF::URL::isHierarchical const): Deleted.
* Source/WTF/wtf/URL.h:
(WTF::URL::hasOpaquePath const):
(WTF::URL::canSetHostOrPort const): Deleted.
(WTF::URL::canSetPathname const): Deleted.
(WTF::URL::cannotBeABaseURL const): Deleted.
* Source/WTF/wtf/URLParser.cpp:
(WTF::URLParser::URLParser):
(WTF::URLParser::parse):
(WTF::URLParser::allValuesEqual):
* Source/WebCore/html/URLDecomposition.cpp:
(WebCore::URLDecomposition::setUsername):
(WebCore::URLDecomposition::setPassword):
(WebCore::URLDecomposition::setHost):
(WebCore::URLDecomposition::setHostname):
(WebCore::URLDecomposition::setPort):
(WebCore::URLDecomposition::setPathname):
* Source/WebCore/page/csp/ContentSecurityPolicy.cpp:
(WebCore::shouldReportProtocolOnly):

Canonical link: https://commits.webkit.org/266090@main




More information about the webkit-changes mailing list