[webkit-changes] [WebKit/WebKit] 07b555: [Apple Pay] Deprecate `enabled` in favor of `avail...
Abrar Rahman Protyasha
noreply at github.com
Tue Aug 1 14:30:48 PDT 2023
Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 07b5559f651ee6ed1e95391fea5bf353ea3b9a72
https://github.com/WebKit/WebKit/commit/07b5559f651ee6ed1e95391fea5bf353ea3b9a72
Author: Abrar Rahman Protyasha <a_protyasha at apple.com>
Date: 2023-08-01 (Tue, 01 Aug 2023)
Changed paths:
M LayoutTests/http/tests/paymentrequest/paymentrequest-shippingContactEditingMode.https.html
M Source/WebCore/Modules/applepay/ApplePayShippingContactEditingMode.h
M Source/WebCore/Modules/applepay/ApplePayShippingContactEditingMode.idl
M Source/WebCore/Modules/applepay/PaymentCoordinator.cpp
M Source/WebKit/Shared/ApplePay/PaymentSetupConfiguration.mm
M Source/WebKit/Shared/ApplePay/cocoa/WebPaymentCoordinatorProxyCocoa.mm
Log Message:
-----------
[Apple Pay] Deprecate `enabled` in favor of `available` in ApplePayShippingContactEditingMode
https://bugs.webkit.org/show_bug.cgi?id=259659
rdar://113159800
Reviewed by Wenson Hsieh.
In iOS 17, PassKit is deprecating PKShippingContactEditingModeEnabled in
favor of PKShippingContactEditingModeAvailable in the
PKShippingContactEditingMode enumeration. Reference: https://developer.apple.com/documentation/passkit/pkshippingcontacteditingmode/pkshippingcontacteditingmodeenabled?language=objc
Given our intention to reflect the PassKit public API in the Apple Pay
JS API, we should follow suit and perform a similar deprecation. We do
so by introducing `available`, the preferred enumeration value, and
logging a console warning whenever a PaymentSession is inititated with a
PaymentRequest containing the deprecated `shippingContactEditingMode`
value.
* LayoutTests/http/tests/paymentrequest/paymentrequest-shippingContactEditingMode.https.html:
* Source/WebCore/Modules/applepay/ApplePayShippingContactEditingMode.h:
* Source/WebCore/Modules/applepay/ApplePayShippingContactEditingMode.idl:
* Source/WebCore/Modules/applepay/PaymentCoordinator.cpp:
(WebCore::PaymentCoordinator::beginPaymentSession):
* Source/WebKit/Shared/ApplePay/PaymentSetupConfiguration.mm:
Drive-by fix of a mismatched namespace.
* Source/WebKit/Shared/ApplePay/cocoa/WebPaymentCoordinatorProxyCocoa.mm:
(WebKit::toPKShippingContactEditingMode):
Canonical link: https://commits.webkit.org/266493@main
More information about the webkit-changes
mailing list