<html><head>

<style id="css_styles" type="text/css">blockquote.cite { margin-left: 5px; margin-right: 0px; padding-left: 10px; padding-right:0px; border-left: 1px solid #cccccc }
blockquote.cite2 {margin-left: 5px; margin-right: 0px; padding-left: 10px; padding-right:0px; border-left: 1px solid #cccccc; margin-top: 3px; padding-top: 0px; }
a img { border: 0px; }
li[style='text-align: center;'], li[style='text-align: right;'] {  list-style-position: inside;}
body { font-family: Verdana; font-size: 12px;   }</style></head><body class="plain" style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;"><div><div>Adrian wrote...</div>
</div><div><br /></div>
<div id="xb52ebbcf33434f1"><blockquote type="cite" class="cite2"><div class="plain_line">One thing that I forgot to mention in my previous e-mail is that it is better</div>
<div class="plain_line">to use a version of WebKitGTK (for GNOME Web on the desktop) from the same</div>
<div class="plain_line">release series. For example if you are using WPE WebKit 2.26.x (or 2.27.x)</div>
<div class="plain_line">it's a good idea to use make sure that GNOME Web on the Ubuntu box has</div>
<div class="plain_line">WebKitGTK 2.26.x installed. In the case of Ubuntu 19.04 it seems [1] that</div>
<div class="plain_line">distro is stuck in 2.24... An option there would be to use the Flatpak for</div>
<div class="plain_line">the GNOME Web Tech Preview [2] builds (which currently use WebKitGTK 2.26.x),</div>
<div class="plain_line">which should be installable from the command line easily:</div>
<div class="plain_line"> </div>
<div class="plain_line">  $ flatpak install --from https://webkitgtk.org/epiphany-tech-preview</div></blockquote>I have run the flatpak command on my Ubuntu 19.10 vm and GNOME Web is reporting WebKitGTK 2.26.1 and the target is running WPE WebKit 2.27.2 and there is still no output shown in the remote inspector.</div><div id="xb52ebbcf33434f1"><br /><blockquote type="cite" class="cite2"><div class="plain_line">Another thing to check is that the “libWPEInspectorResource.so” library has</div>
<div class="plain_line">been installed to the target device. If you are using the Yocto recipes from</div>
<div class="plain_line">meta-webkit, you need to add the “wpewebkit-web-inspector-plugin” package to</div>
<div class="plain_line">your images (on the other hand, the Buildroot package always installs it).</div></blockquote>There is a file on the target called libWPEWebInspectorResources.so which is in /usr/lib/wpe-webkit-1.0.  Is this file being automatically picked up or is there something needs adding to the command like to reference it?</div><div id="xb52ebbcf33434f1"><br /></div><div id="xb52ebbcf33434f1">-Andy.</div><div id="xb52ebbcf33434f1"><br /></div><div id="xb52ebbcf33434f1"><br /><blockquote type="cite" class="cite2">
</blockquote></div>
</body></html>