[wpe-webkit] 2.30.1 fails to build

zan at falconsigh.net zan at falconsigh.net
Fri Oct 2 02:27:12 PDT 2020


On Thu, Oct 1, 2020, at 11:20 AM, Andrea Giammarchi wrote:
> Dear WPEWebKit folks,
>   I am struggling to build 2.30.1 due a FilterOperation error, no matter which flag I enable ordisable, a build from scratch would always fail.
> 
> Building on top on 2.28 works though, but basically I can't build WPEWebKit anymore from new machines, unless I build 2.28 first and then change its sources to build 2.30.

Can you provide more information about the build system and the build command? I can see usage of GCC 10, but beyond that not much is deducible.

I was able to build 2.30.1 without problems on a Debian Bullseye system, using GCC 10 and GStreamer 1.18.0.

> _______________________________________________
> Do not post admin requests to the list. They will be ignored.
> webkit-wpe mailing list      (webkit-wpe at lists.webkit.org)
> Help/Unsubscribe/Update your Subscription:
> https://lists.webkit.org/mailman//listinfo/webkit-wpe
> 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-wpe/attachments/20201002/22507679/attachment.htm>


More information about the webkit-wpe mailing list