<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><span class="vcard"><a class="email" href="mailto:post@jelmerdemaat.nl" title="Jelmer de Maat <post@jelmerdemaat.nl>"> <span class="fn">Jelmer de Maat</span></a>
</span> changed
          <a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - em-based media queries in <source> are relative to <html> instead of browser default font"
   href="https://bugs.webkit.org/show_bug.cgi?id=159635">bug 159635</a>
          <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">CC</td>
           <td>
                
           </td>
           <td>post@jelmerdemaat.nl
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - em-based media queries in <source> are relative to <html> instead of browser default font"
   href="https://bugs.webkit.org/show_bug.cgi?id=159635#c8">Comment # 8</a>
              on <a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - em-based media queries in <source> are relative to <html> instead of browser default font"
   href="https://bugs.webkit.org/show_bug.cgi?id=159635">bug 159635</a>
              from <span class="vcard"><a class="email" href="mailto:post@jelmerdemaat.nl" title="Jelmer de Maat <post@jelmerdemaat.nl>"> <span class="fn">Jelmer de Maat</span></a>
</span></b>
        <pre>We also experience this bug.

Tested on: iOS 11, 14 and 15. This is still an ongoing issue in all of these versions.

See a demonstration of this issue here (use an iPad): 

<a href="https://cdpn.io/jelmerdemaat/debug/qBXPLyv/dGrXWjopoLmM">https://cdpn.io/jelmerdemaat/debug/qBXPLyv/dGrXWjopoLmM</a>

The spec mentioned earlier ("Relative units in media queries are based on the initial value, which means that units are never based on results of declarations") is not followed. 

When applying a custom font-size to the html element, the outcome of the media query inside <source> elements changes. This is not expected behaviour. It seems like the computed screen width is incorrect.

Other browsers (Chrome, Firefox, Edge) correctly adhere to the font-size defined in the browser, ignoring   any declarations.

Best regards,
Jelmer</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>