<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - REGRESSION(r283674) [WPE] Bots exiting early with lots of tests timing out"
   href="https://bugs.webkit.org/show_bug.cgi?id=231413">231413</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>REGRESSION(r283674) [WPE] Bots exiting early with lots of tests timing out
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>WebKit Nightly Build
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>WebKit Misc.
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>lmoura@igalia.com
          </td>
        </tr></table>
      <p>
        <div>
        <pre>Non-exhaustive list:

fast/canvas/webgl/texImage2D-video-flipY-false.html
fast/dom/focus-shift-crash.html
fast/events/constructors/track-event-constructor.html
fast/events/media-focus-in-standalone-media-document.html
fast/history/page-cache-media-source-closed-2.html
fast/history/page-cache-removed-source-buffer.html
fast/mediastream/apply-constraints-advanced.html
fast/mediastream/apply-constraints-audio.html
fast/mediastream/apply-constraints-video.html
fast/mediastream/captureStream/canvas2d-heavy-drawing.html
fast/mediastream/captureStream/canvas2d.html
fast/mediastream/get-user-media-on-loadedmetadata.html
fast/mediastream/local-audio-playing-event.html
fast/mediastream/media-stream-renders-first-frame.html
fast/mediastream/MediaStream-MediaElement-setObject-null.html
fast/mediastream/MediaStream-video-element-displays-buffer.html
fast/mediastream/MediaStream-video-element-remove-track.html
fast/mediastream/MediaStream-video-element-video-tracks-disabled.html
fast/mediastream/MediaStream-video-element.html
fast/rendering/iframe-window-animation-modifies-iframe-srcdoc-crash.html
fast/scrolling/scrolling-inside-scrolled-overflowarea.html
fullscreen/full-screen-iframe-legacy.html
fullscreen/fullscreen-restore-scroll-position.html
fullscreen/video-inside-flex-item.html
fullscreen/video-specified-size.html
http/tests/appcache/video.html
http/tests/cache/disk-cache/disk-cache-media-small.html
http/tests/contentextensions/media-filtered.html
http/tests/history/back-to-post.py      expected actual diff pretty diff        history
http/tests/media/hls/hls-audio-tracks-has-audio.html
http/tests/media/hls/hls-audio-tracks.html
http/tests/media/hls/hls-progress.html
http/tests/media/media-document-referer.html
http/tests/media/media-document.html
http/tests/media/media-play-stream-chunked-icy.html
http/tests/media/media-seeking-no-ranges-server.html
http/tests/media/media-source/mediasource-play-then-seek-back-with-remote-control.html
http/tests/media/pdf-served-as-pdf.html
http/tests/media/reload-after-dialog.html
http/tests/media/remove-while-loading.html
http/tests/media/text-served-as-text.html
http/tests/media/track/track-webvtt-slow-loading-2.html
http/tests/media/track/track-webvtt-slow-loading.html
http/tests/misc/empty-urls.html
http/tests/navigation/page-cache-video.html

Many are timing out with errors creating the video element (methods like load, canPlayType, etc being undefined). for example, in `http/tests/misc/empty-urls.html`:


--- /home/lauro/dev/WebKit/layout-test-results/http/tests/misc/empty-urls-expected.txt
+++ /home/lauro/dev/WebKit/layout-test-results/http/tests/misc/empty-urls-actual.txt
@@ -1,7 +1,7 @@
+CONSOLE MESSAGE: TypeError: document.getElementById("video").load is not a function. (In 'document.getElementById("video").load()', 'document.getElementById("video").load' is undefined)
+FAIL: Timed out waiting for notifyDone to be called
+
 PASS: img onerror fired
 PASS: input type=image onerror fired
 PASS: script onerror fired
-PASS: video src onerror fired
-PASS: audio onerror fired
-PASS: source onerror fired

In GTK, a similar set of tests were failing until <a href="https://commits.webkit.org/r283707">r283707</a> reenabled visibility=hidden (started passing again since).


PS: There's also an issue bisecting where, if I went back in history a few commits, the test just times out without any output.

Testing on buildbox2, everything seems to be working there.</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>