<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Page does not reload properly when cold starting Safari"
   href="https://bugs.webkit.org/show_bug.cgi?id=230343">230343</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>Page does not reload properly when cold starting Safari
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>Safari Technology Preview
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>History
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>mads@langesund.org
          </td>
        </tr></table>
      <p>
        <div>
        <pre>When opening Safari "cold" (aka. exiting Safari and opening later), the current page is loaded with stale/old content, even though I use `Cache-Control: max-age=0, must-revalidate`. The user has to manually reload the page to get the updated content.
I can use `Cache-Control: no-store` to force reloading, but that would break BFCache, which is somewhat critical for the user experience.

This bug is present in Safari 14 and latest Safari 15.

Is there something I'm missing? Should I do a workaround?</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>