<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [WPE][GTK] WebKitWebView:is-web-process-responsive seems to become FALSE too aggressively?"
   href="https://bugs.webkit.org/show_bug.cgi?id=228147#c4">Comment # 4</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [WPE][GTK] WebKitWebView:is-web-process-responsive seems to become FALSE too aggressively?"
   href="https://bugs.webkit.org/show_bug.cgi?id=228147">bug 228147</a>
              from <span class="vcard"><a class="email" href="mailto:magomez@igalia.com" title="Miguel Gomez <magomez@igalia.com>"> <span class="fn">Miguel Gomez</span></a>
</span></b>
        <pre>I'm afraid WebKit only waits 3 seconds for an answer from the web process before marking it as unresponsive. This is not a lot and, as Adrian mentions, if the system is loaded some views can be marked as unresponsive despite they are just slow.

Those 3 seconds are the default value used by Apple as well. We could increase the value for our ports if we think it's too small, or the browser could wait some extra time once the flag is activated to ensure that the process stays unresponsive for a while. Not sure what's the best option here.</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>