<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - run-javascriptcore-tests won't report test results for testmasm, testair, testb3, testdfg and test api"
   href="https://bugs.webkit.org/show_bug.cgi?id=199489#c52">Comment # 52</a>
              on <a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - run-javascriptcore-tests won't report test results for testmasm, testair, testb3, testdfg and test api"
   href="https://bugs.webkit.org/show_bug.cgi?id=199489">bug 199489</a>
              from <span class="vcard"><a class="email" href="mailto:zhifei_fang@apple.com" title="Zhifei Fang <zhifei_fang@apple.com>"> <span class="fn">Zhifei Fang</span></a>
</span></b>
        <pre>(In reply to Guillaume Emont from <a href="show_bug.cgi?id=199489#c51">comment #51</a>)
<span class="quote">> (In reply to Zhifei Fang from <a href="show_bug.cgi?id=199489#c50">comment #50</a>)
> > (In reply to Guillaume Emont from <a href="show_bug.cgi?id=199489#c48">comment #48</a>)
> > > (In reply to Guillaume Emont from <a href="show_bug.cgi?id=199489#c47">comment #47</a>)
> > > > This definitely breaks the arm and mips EWS.
> > > 
> > > Example test output from arm bot (we get the same on the mips bot):
> > > <a href="https://webkit-queues.webkit.org/results/12741762">https://webkit-queues.webkit.org/results/12741762</a>
> > > 
> > > I believe that additional code is needed to disable the binary test report
> > > on these archs.
> > 
> > This is weird, it works well here:
> > 
> > <a href="https://build.webkit.org/builders/JSCOnly%20Linux%20MIPS32el%20Release/">https://build.webkit.org/builders/JSCOnly%20Linux%20MIPS32el%20Release/</a>
> > builds/3310/steps/jscore-test/logs/stdio
> > 
> > Most likely either I miss something, or I miss to restart something.
> > 
> > aakash_jain, any instruction here ?

> Buildbots and (old) EWS don't use the same scripts. So I think we're in a
> situation where the buildbots properly ignore the results of tesmasm & co,
> whereas the EWS looks at them.
> I would guess we might need to add code in
> Tools/Scripts/webkitpy/common/config/ports.py or somewhere around that so
> that we also pass the --no-testmasm... options for the old EWS.
> Alternatively, if this looks unfeasible, I can try to add this to the
> $JSCTESTS_OPTIONS environment variable of jsc-mips-ews and jsc-armv7-ews.</span >

I guess I will need to modify the old EWS code as well.</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>