<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [GTK][WPE] libgcrypt-1.7.6 can't be compiled on Ubuntu 18.10"
   href="https://bugs.webkit.org/show_bug.cgi?id=193643">193643</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>[GTK][WPE] libgcrypt-1.7.6 can't be compiled on Ubuntu 18.10
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>WebKit Nightly Build
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>WebKit Gtk
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>Hironori.Fujii@sony.com
          </td>
        </tr>

        <tr>
          <th>CC</th>
          <td>bugs-noreply@webkitgtk.org
          </td>
        </tr></table>
      <p>
        <div>
        <pre>[GTK][WPE] libgcrypt-1.7.6 can't be compiled on Ubuntu 18.10

update-webkitgtk-libs is failing with the following error.

<span class="quote">>  /bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I/home/fujii/webkit/ga/WebKitBuild/DependenciesGTK/Source/libgcrypt-1.7.6/cipher -I..  -I../src -I/home/fujii/webkit/ga/WebKitBuild/DependenciesGTK/Source/libgcrypt-1.7.6/src  -I/home/fujii/webkit/ga/WebKitBuild/DependenciesGTK/Root/include -Wno-error -O2 -g1 -fvisibility=hidden -Wall -MT camellia.lo -MD -MP -MF .deps/camellia.Tpo -c -o camellia.lo /home/fujii/webkit/ga/WebKitBuild/DependenciesGTK/Source/libgcrypt-1.7.6/cipher/camellia.c
> In file included from /usr/include/features.h:424,
>                  from /usr/include/x86_64-linux-gnu/bits/libc-header-start.h:33,
>                  from /usr/include/stdio.h:27,
>                  from /home/fujii/webkit/ga/WebKitBuild/DependenciesGTK/Source/libgcrypt-1.7.6/cipher/rijndael-ssse3-amd64.c:38:
> /home/fujii/webkit/ga/WebKitBuild/DependenciesGTK/Source/libgcrypt-1.7.6/cipher/rijndael-ssse3-amd64.c: In function '_gcry_aes_ssse3_do_setkey':
> /usr/include/x86_64-linux-gnu/bits/string_fortified.h:31:1: error: inlining failed in call to always_inline 'memcpy': target specific option mismatch
>  __NTH (memcpy (void *__restrict __dest, const void *__restrict __src,
>  ^~~~~</span ></pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>