<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - video element's content don't fill available width"
   href="https://bugs.webkit.org/show_bug.cgi?id=193020">193020</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>video element's content don't fill available width
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>Safari 12
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Macintosh
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>macOS 10.14
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>Layout and Rendering
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>corsar89@ya.ru
          </td>
        </tr>

        <tr>
          <th>CC</th>
          <td>bfulgham@webkit.org, simon.fraser@apple.com, zalan@apple.com
          </td>
        </tr></table>
      <p>
        <div>
        <pre>Video elements' content doesn't fill all available space on some resolutions, I assume problem occurs when video element's width becomes fractional. 

As all available space, I mean area painted by background-color


<a href="https://jsfiddle.net/uzr0wp9h/2/">https://jsfiddle.net/uzr0wp9h/2/</a>

Here is example of the video with red background, background is visible on the right edge of the video.

Desired behavior: video content should have the same width as video element and no background should be visible


Bug reproduced in Chrome too. Firefox and Edge are okay with it.</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>