<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - REGRESSION(r235484) _WKPreferencesGetWebRTCLegacyAPIEnabled symbol not found when running Safari with external SDK build"
   href="https://bugs.webkit.org/show_bug.cgi?id=189188">189188</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>REGRESSION(r235484) _WKPreferencesGetWebRTCLegacyAPIEnabled symbol not found when running Safari with external SDK build
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>WebKit Nightly Build
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>WebRTC
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>fred.wang@free.fr
          </td>
        </tr>

        <tr>
          <th>CC</th>
          <td>rwlbuis@gmail.com, youennf@gmail.com
          </td>
        </tr></table>
      <p>
        <div>
        <pre>After the change in <a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED FIXED - Remove WebRTC legacy API implementation"
   href="show_bug.cgi?id=189040">bug 189040</a>, I can no longer run Safari (iOS or macOS) using the external SDK:

$ Tools/Scripts/run-safari 
Starting SafariForWebKitDevelopment with DYLD_FRAMEWORK_PATH set to point to built WebKit in /Users/fred/WebKit/WebKitBuild//Debug.
dyld: Symbol not found: _WKPreferencesGetWebRTCLegacyAPIEnabled
  Referenced from: /System/Library/PrivateFrameworks/Safari.framework/Versions/A/Safari
  Expected in: /Users/fred/WebKit/WebKitBuild/Debug/WebKit.framework/Versions/A/WebKit
 in /System/Library/PrivateFrameworks/Safari.framework/Versions/A/Safari</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>