<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - iOS 11.4 breaks video playback in Cordova apps"
   href="https://bugs.webkit.org/show_bug.cgi?id=186353#c3">Comment # 3</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - iOS 11.4 breaks video playback in Cordova apps"
   href="https://bugs.webkit.org/show_bug.cgi?id=186353">bug 186353</a>
              from <span class="vcard"><a class="email" href="mailto:bfulgham@webkit.org" title="Brent Fulgham <bfulgham@webkit.org>"> <span class="fn">Brent Fulgham</span></a>
</span></b>
        <pre>This behavior change started with <a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED FIXED - Add createImageBitmap to Window and Worker"
   href="show_bug.cgi?id=178573">Bug 178573</a>, where we began supporting createImageBitmap. That caused this test app to not display audio or video.

Later, in <a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED FIXED - Implement createImageBitmap(Blob)"
   href="show_bug.cgi?id=183247">Bug 183247</a>, audio began working again when Blob support was added.

I think we actually have an issue where an underling Cordova component sees that 'createImageBitmap' is available and tries to use it.

Unfortunately, createImageBitmap with ImageData is not currently implemented, which causes us to return a blank ImageBitmap.

I don't know how to do further debugging in Cordova, but I think this is just a compatibility issue due to the incomplete createImageBitmap implementation.</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>