<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - [GTK] FindController: search occurrences not highlighted after loading new page"
   href="https://bugs.webkit.org/show_bug.cgi?id=185798">185798</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>[GTK] FindController: search occurrences not highlighted after loading new page
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>Other
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>PC
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Linux
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>WebKit Gtk
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>swilmet@gnome.org
          </td>
        </tr>

        <tr>
          <th>CC</th>
          <td>bugs-noreply@webkitgtk.org
          </td>
        </tr></table>
      <p>
        <div>
        <pre>[GTK] FindController: search occurrences not highlighted after loading new page.

I think it's a bug in WebKitFindController:
1. webkit_find_controller_search() is called --> the search occurrences are correctly highlighted.
2. The WebKitWebView loads another page --> the search occurrences are not highlighted in the new page content, but webkit_find_controller_get_search_text() still returns the same search text that was previously set.

The Devhelp bug:
<a href="https://bugzilla.gnome.org/show_bug.cgi?id=793716">https://bugzilla.gnome.org/show_bug.cgi?id=793716</a>

As explained in the Devhelp bug, Epiphany is good at avoiding this bug :-)</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>