<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Negative animation-delay isn't picked up when an animation is paused"
   href="https://bugs.webkit.org/show_bug.cgi?id=184087">184087</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>Negative animation-delay isn't picked up when an animation is paused
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>WebKit Nightly Build
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>Animations
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>matias.niemela@gmail.com
          </td>
        </tr>

        <tr>
          <th>CC</th>
          <td>dino@apple.com
          </td>
        </tr></table>
      <p>
        <div>
        <pre>In addition to the problems with Webkit Negative Animation Delays...
<a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - Negative animation-delay is treated as 0s"
   href="show_bug.cgi?id=141008">https://bugs.webkit.org/show_bug.cgi?id=141008</a>
<a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED FIXED - Negative values for animation-delay are ignored (treated as zero)"
   href="show_bug.cgi?id=26150">https://bugs.webkit.org/show_bug.cgi?id=26150</a>

It would be very helpful is Webkit (Safari in this case) would allow itself to change the negative delay value as much as needed before an animation starts.

Chrome/Firefox allow for this and in turn you can basically scrub a @keyframes animation.

```
// file: index.js

// assign a keyframe to an element
var ANIMATION_DURATION = 1000;
element.style.setProperty('animation', 'myKeyframe ' + ANIMATION_DURATION);

// pause the video before it kicks off
element.style.setProperty('animation-play-state', 'paused');

// change the delay based on some <input type="range"> input

// rangeInput = <input type="range" min="0" max="1" step="0.01">
rangeInput.addEventListener('input', function(e) {

  // this DOES NOT work in Webkit/Safari (Chrome and Firefox are good).
  element.style.setProperty('animation-delay', this.value * ANIMATION_DURATION);
});


```</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>