<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><span class="vcard"><a class="email" href="mailto:sfroberg13@yahoo.com" title="Stefan Fröberg <sfroberg13@yahoo.com>"> <span class="fn">Stefan Fröberg</span></a>
</span> changed
          <a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED WONTFIX - Cmake for static build of libjavascriptcoregtk and libwebkit2gtk fails: install TARGETS given no ARCHIVE DESTINATION for static library target "WebKit"."
   href="https://bugs.webkit.org/show_bug.cgi?id=183595">bug 183595</a>
          <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">CC</td>
           <td>
                
           </td>
           <td>sfroberg13@yahoo.com
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED WONTFIX - Cmake for static build of libjavascriptcoregtk and libwebkit2gtk fails: install TARGETS given no ARCHIVE DESTINATION for static library target "WebKit"."
   href="https://bugs.webkit.org/show_bug.cgi?id=183595#c2">Comment # 2</a>
              on <a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED WONTFIX - Cmake for static build of libjavascriptcoregtk and libwebkit2gtk fails: install TARGETS given no ARCHIVE DESTINATION for static library target "WebKit"."
   href="https://bugs.webkit.org/show_bug.cgi?id=183595">bug 183595</a>
              from <span class="vcard"><a class="email" href="mailto:sfroberg13@yahoo.com" title="Stefan Fröberg <sfroberg13@yahoo.com>"> <span class="fn">Stefan Fröberg</span></a>
</span></b>
        <pre>
Add this to Source/WebKit/CMakeLists.txt

install(TARGETS WebKit WebProcess NetworkProcess
        ARCHIVE DESTINATION "${LIB_INSTALL_DIR}"
        LIBRARY DESTINATION "${LIB_INSTALL_DIR}"
        RUNTIME DESTINATION "${LIBEXEC_INSTALL_DIR}"
    )


Actually, I managed to get static JavaScriptCore work, but it was only after I switched static musl compiled *Process files with static glibc compiled process files. Then it worked.

But still as today, have no clue why the musl-compiled three *Process files caused the problem .....</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>