<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Layout Test webrtc/datachannel/basic-tcp.html is flaky"
   href="https://bugs.webkit.org/show_bug.cgi?id=183423">183423</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>Layout Test webrtc/datachannel/basic-tcp.html is flaky
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>WebKit Nightly Build
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>New Bugs
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>jlewis3@apple.com
          </td>
        </tr>

        <tr>
          <th>CC</th>
          <td>jbedard@apple.com, ryanhaddad@apple.com, youennf@gmail.com
          </td>
        </tr></table>
      <p>
        <div>
        <pre>Created <span class=""><a href="attachment.cgi?id=335245" name="attach_335245" title="crash-log">attachment 335245</a> <a href="attachment.cgi?id=335245&action=edit" title="crash-log">[details]</a></span>
crash-log

The following layout test is flaky on macOS Debug WK2

webrtc/datachannel/basic-tcp.html

The test is showing up as an invalid crash in com.apple.WebKit.Networking.Development however the bots are stating there is no crash.

Flakiness Dashboard:

<a href="https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=webrtc%2Fdatachannel%2Fbasic-tcp.html">https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=webrtc%2Fdatachannel%2Fbasic-tcp.html</a>


I got a log from one of the bots:

Thread 5 Crashed:: com.apple.NSURLConnectionLoader
0   libobjc.A.dylib                     0x00007fffa920901d objc_msgSend + 29
1   com.apple.Foundation                0x7fff957d3716 +[NSConcreteNotification newTempNotificationWithName:object:userInfo:] + 123 (/Library/Caches/com.apple.xbs/Sources/Foundation/Foundation-1349.91/Misc.subproj/NSNotification.m:211)
2   com.apple.Foundation                0x7fff957d365f -[NSNotificationCenter postNotificationName:object:userInfo:] + 42 (/Library/Caches/com.apple.xbs/Sources/Foundation/Foundation-1349.91/Misc.subproj/NSNotification.m:499)
3   com.apple.CoreFoundation            0x7fff93dde3e1 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17 (~rc/Software/SUFujiSecChipmunk/Projects/CF/CF-1349.90/RunLoop.subproj/CFRunLoop.c:1943)
4   com.apple.CoreFoundation            0x7fff93dbf65c __CFRunLoopDoSources0 + 556 (~rc/Software/SUFujiSecChipmunk/Projects/CF/CF-1349.90/RunLoop.subproj/CFRunLoop.c:1989)
5   com.apple.CoreFoundation            0x7fff93dbeb46 __CFRunLoopRun + 934 (~rc/Software/SUFujiSecChipmunk/Projects/CF/CF-1349.90/RunLoop.subproj/CFRunLoop.c:2821)
6   com.apple.CoreFoundation            0x7fff93dbe544 CFRunLoopRunSpecific + 420 (~rc/Software/SUFujiSecChipmunk/Projects/CF/CF-1349.90/RunLoop.subproj/CFRunLoop.c:3113)
7   com.apple.CFNetwork                 0x7fff92ef9344 +[NSURLConnection(Loader) _resourceLoadLoop:] + 313 (/BuildRoot/Library/Caches/com.apple.xbs/Sources/CFNetwork/CFNetwork-811.8/Foundation/NSURLConnection.mm:364)
8   com.apple.Foundation                0x7fff957ff8ad __NSThread__start__ + 1243 (/Library/Caches/com.apple.xbs/Sources/Foundation/Foundation-1349.91/Soil.subproj/NSThread.m:1163)
9   libsystem_pthread.dylib             0x7fffa9d1193b _pthread_body + 180 (/BuildRoot/Library/Caches/com.apple.xbs/Sources/libpthread/libpthread-218.60.3/src/pthread.c:697)
10  libsystem_pthread.dylib             0x7fffa9d11887 _pthread_start + 286 (/BuildRoot/Library/Caches/com.apple.xbs/Sources/libpthread/libpthread-218.60.3/src/pthread.c:744)
11  libsystem_pthread.dylib             0x00007fffa9d1108d thread_start + 13


Attached the crash log.</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>