<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Layout Test media/modern-media-controls/volume-support/volume-support-drag.html is a flaky failure"
   href="https://bugs.webkit.org/show_bug.cgi?id=183228">183228</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>Layout Test media/modern-media-controls/volume-support/volume-support-drag.html is a flaky failure
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>Other
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>Media Elements
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>ryanhaddad@apple.com
          </td>
        </tr></table>
      <p>
        <div>
        <pre>The following layout test is flaky on macOS Debug WK2

media/modern-media-controls/volume-support/volume-support-drag.html

Probable cause:

Unknown. The first failure on the dashboard blames <a href="https://trac.webkit.org/log/?verbose=on&rev=228041&stop_rev=228039">https://trac.webkit.org/log/?verbose=on&rev=228041&stop_rev=228039</a>, but those seem to be unrelated.

Flakiness Dashboard:

<a href="https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=media%2Fmodern-media-controls%2Fvolume-support%2Fvolume-support-drag.html">https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=media%2Fmodern-media-controls%2Fvolume-support%2Fvolume-support-drag.html</a>

--- /Volumes/Data/slave/sierra-debug-tests-wk2/build/layout-test-results/media/modern-media-controls/volume-support/volume-support-drag-expected.txt
+++ /Volumes/Data/slave/sierra-debug-tests-wk2/build/layout-test-results/media/modern-media-controls/volume-support/volume-support-drag-actual.txt
@@ -6,19 +6,15 @@
 By default, the volume slider should be set to 0 because the media is muted
 PASS mediaController.controls.volumeSlider.value is 0
 PASS muteButton.getBoundingClientRect().width became different from 0
-PASS volumeSlider.getBoundingClientRect().width became different from 0
-
-Before starting to drag the volume slider, the media should be muted still
-PASS media.muted is true
-
-We initiated a volume slider drag, the media should no longer be muted and the volume set
-PASS media.muted became false
-PASS media.volume became 0.51
-
-We finished dragging to set the volume to 1
-PASS media.volume became 1
-PASS mediaController.controls.volumeSlider.parent.visible is true
 PASS successfullyParsed is true

 TEST COMPLETE

+
+
+
+
+00:00
+
+-00:00
+</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>