<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Audio sometimes fail to capture in WebRTC"
   href="https://bugs.webkit.org/show_bug.cgi?id=180748#c1">Comment # 1</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Audio sometimes fail to capture in WebRTC"
   href="https://bugs.webkit.org/show_bug.cgi?id=180748">bug 180748</a>
              from <span class="vcard"><a class="email" href="mailto:daginge@confrere.com" title="daginge@confrere.com">daginge</a>
</span></b>
        <pre>From my testing:

- If it works the first time (when you open the tab), it will continue to work every time for that tab, even if you reload, or call getUserMedia again and replace the stream being played.
- If it doesn't work when you open the tab, it will never work no matter how many times you call getUserMedia  and replace the played back stream.
- Clicking the controls manually does not change anything.
- If a tab didn't work, sometimes it can start working on reload, but most likely, it will never work.

// test code run in dev console from Safari Desktop Remote Debugging to iPad Safari
a = document.getElementById("gum-local");
navigator.mediaDevices.getUserMedia({ video: true, audio: true}).then(stream => a.srcObject = stream).catch(console.log)</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>