<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Symbol not found: __ZN3WTF8LockBase10unlockSlowEv"
   href="https://bugs.webkit.org/show_bug.cgi?id=180691">180691</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>Symbol not found: __ZN3WTF8LockBase10unlockSlowEv
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>WebKit Nightly Build
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Unspecified
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>New Bugs
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>webkit@devinrousso.com
          </td>
        </tr></table>
      <p>
        <div>
        <pre>I just tried running my local build via `Tools/Scripts/run-safari --release` and got this error:

Starting SafariForWebKitDevelopment with DYLD_FRAMEWORK_PATH set to point to built WebKit in WebKitBuild/Release.
dyld: Symbol not found: __ZN3WTF8LockBase10unlockSlowEv
  Referenced from: /System/Library/PrivateFrameworks/Safari.framework/Versions/A/Safari
  Expected in: WebKitBuild/Release/JavaScriptCore.framework/Versions/A/JavaScriptCore
 in /System/Library/PrivateFrameworks/Safari.framework/Versions/A/Safari

I'm guessing that this is related to <<a class="bz_bug_link 
          bz_status_RESOLVED  bz_closed"
   title="RESOLVED FIXED - [WTF] Remove XXXLockBase since constexpr constructor can initialize static variables without calling global constructors"
   href="show_bug.cgi?id=180495">https://webkit.org/b/180495</a>>, as it removed LockBase.

* Info:
ProductName:    Mac OS X
ProductVersion: 10.13.2
BuildVersion:   17C88</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>