<html>
    <head>
      <base href="https://bugs.webkit.org/">
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - Safari 11 crashing on minified JS"
   href="https://bugs.webkit.org/show_bug.cgi?id=177482">177482</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>Safari 11 crashing on minified JS
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>WebKit
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>Safari Technology Preview
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Macintosh
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>macOS 10.12.4
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>Major
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>P2
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>New Bugs
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>webkit-unassigned@lists.webkit.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>brian@dockyard.com
          </td>
        </tr></table>
      <p>
        <div>
        <pre>Our site: <a href="https://hightide.earth">https://hightide.earth</a> fails to load on initial load. If you refresh it will load as expected. If you close Safari 11 and hit the URL again it will crash again.

The LOC that appears to be affected relates to Google Analytics. The app initializer is attempting to instantiate the GA library with our user key. The code is minified and using AMDs from an Ember.js application.

Because Safari does not allow me to open the JS console prior to visiting any site I cannot debug this. If I visit another site, open JS console, then visit <a href="https://hightide.earth">https://hightide.earth</a> the app works as expected. So this is only happening when Hightide is the first app visited in a fresh instance of Safari.

The console error in question: `(0,a.default) is not a function. (In '(0,a.default)("create","UA-24185112-11","auto")', '(0,a.default)' is an instance of Object)`

Again, this is only a problem in a fresh instance of Safari. If I reload the app works as expected. If I visit from another URL the app works as expected. And I have no observed this error in any other browser.</pre>
        </div>
      </p>


      <hr>
      <span>You are receiving this mail because:</span>

      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>