<html>
    <head>
      <base href="https://bugs.webkit.org/" />
    </head>
    <body>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - EWS should run JavaScriptCore tests"
   href="https://bugs.webkit.org/show_bug.cgi?id=162458#c37">Comment # 37</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - EWS should run JavaScriptCore tests"
   href="https://bugs.webkit.org/show_bug.cgi?id=162458">bug 162458</a>
              from <span class="vcard"><a class="email" href="mailto:svijayaraghavan&#64;apple.com" title="Sri Vijayaraghavan &lt;svijayaraghavan&#64;apple.com&gt;"> <span class="fn">Sri Vijayaraghavan</span></a>
</span></b>
        <pre>(In reply to <a href="show_bug.cgi?id=162458#c36">comment #36</a>)
<span class="quote">&gt; Comment on <span class=""><a href="attachment.cgi?id=301069&amp;action=diff" name="attach_301069" title="Patch">attachment 301069</a> <a href="attachment.cgi?id=301069&amp;action=edit" title="Patch">[details]</a></span>
&gt; Patch
&gt; 
&gt; View in context:
&gt; <a href="https://bugs.webkit.org/attachment.cgi?id=301069&amp;action=review">https://bugs.webkit.org/attachment.cgi?id=301069&amp;action=review</a>
&gt; 
&gt; &gt; Tools/Scripts/webkitpy/common/net/jsctestresults.py:32
&gt; &gt; +        intersection_api_tests_passed = first._all_api_tests_passed or second._all_api_tests_passed
&gt; 
&gt; please verify whether 'or' or 'and' should be used for intersection.</span >
I know it looks funny, but it should be 'or'. If there are some API test failures the first time, but they all passed the second time, those failures are flaky results, so the reported value of api_tests_passed should be True. There are some examples in the unittests at webkitpy/common/net/jsctestresults_unittest.py.

<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/common/net/jsctestresults.py:44
&gt; &gt; +            return None
&gt; 
&gt; might be a good idea to log a warning as well.</span >
I'll do this.

<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/common/net/jsctestresults_unittest.py:31
&gt; &gt; +        empty_string = &quot;&quot;
&gt; 
&gt; might consider renaming empty_string to empty_json to make it more
&gt; consistent.</span >
I'll do this.

<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:45
&gt; &gt; +        self.failure_status_id = 42
&gt; 
&gt; any specific reason to choose 42? would it make more sense to keep failure
&gt; id as -1?</span >
I'll change it to zero. This becomes a part of the URL to the test results, so it can't be -1.

<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:52
&gt; &gt; +        else:
&gt; 
&gt; 'else' is unnecessary since if returns a value.</span >
I'll fix this.

<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:99
&gt; &gt; +        self.assertEqual(return_value, True)
&gt; 
&gt; should use assertTrue(return_value)
&gt; 
&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:119
&gt; &gt; +        self.assertEqual(return_value, True)
&gt; 
&gt; same, should use assertTrue(return_value)
&gt; 
&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:129
&gt; &gt; +        self.assertEqual(return_value, True)
&gt; 
&gt; same, should use assertTrue(return_value)
&gt; 
&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:139
&gt; &gt; +        self.assertEqual(return_value, True)
&gt; 
&gt; same, should use assertTrue(return_value)
&gt; 
&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:159
&gt; &gt; +        self.assertEqual(return_value, False)
&gt; 
&gt; same, should use assertFalse(return_value)
&gt; 
&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:169
&gt; &gt; +        self.assertEqual(return_value, False)
&gt; 
&gt; same, should use assertFalse(return_value)
&gt; 
&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:179
&gt; &gt; +        self.assertEqual(return_value, False)
&gt; 
&gt; same, should use assertFalse(return_value)
&gt; 
&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:188
&gt; &gt; +        self.assertEqual(return_value, True)
&gt; 
&gt; same, should use assertTrue(return_value)
&gt; 
&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:198
&gt; &gt; +        self.assertEqual(return_value, True)
&gt; 
&gt; same, should use assertTrue(return_value)</span >
&gt;
<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:218
&gt; &gt; +        self.assertEqual(return_value, True)
&gt; 
&gt; same, should use assertTrue(return_value)</span >
I'll fix this set of items.

<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/tool/bot/jscews_unittest.py:209
&gt; &gt; +        self.assertEqual(task.test_run_count(), 3)
&gt; 
&gt; don't we need to assert the return_value here?</span >
There should be no return value in this case, since we expect the function call to raise an exception and not return. For this case, I'll change &quot;return_value = task._test_patch()&quot; to simply &quot;task._test_patch()&quot; since return_value shouldn't be set anyway.

<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/tool/steps/checkpatchrelevance.py:40
&gt; &gt; +    jsc_paths = [
&gt; 
&gt; can consider renaming it to jsc_relevant_paths</span >
I'll do this.

<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/tool/steps/checkpatchrelevance.py:47
&gt; &gt; +    def _does_contain_change_in_paths(self, files, patterns):
&gt; 
&gt; _does_contain_change_in_paths is  misleading name (we are not searching for
&gt; change in path here)</span >
I'll rename the method.

<span class="quote">&gt; &gt; Tools/Scripts/webkitpy/tool/steps/checkpatchrelevance.py:48
&gt; &gt; +        for item in files:
&gt; 
&gt; renaming item to file would make it more readable.</span >
I'll do this.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are the assignee for the bug.</li>
      </ul>
    </body>
</html>